Enabling TRIM for RAID-0 SSD Arrays on 6-Series Motherboard

Note: The following steps include unsupported BIOS modifications which can brick your motherboard. We take no responsibility for failures and the instructions provided below are only for informational purposes. If you still want to try the modification, you are doing it at your own risk and we strongly recommend that you backup all your data before trying any of the steps. 

As I mentioned earlier, you will need either P67 or Z68 for the modification to work. So far other 6-series chipsets have not been tried but you're of course welcome to be the guinea pig (at your own risk, obviously). Next you will need to flash your BIOS in order to apply the modification. This may sound complicated but the actual process is rather easy because most of the work has already been done for you. The actual instructions are rather long because what you need depends on your motherboard, so instead of summarizing I'm just going to link the full instructions. You will need to use a modified OROM version, which can be found here.

Once you have flashed your BIOS with the new OROM, make sure your OROM has indeed been updated to version 11.6.x.xxxx (you will see this when entering the RAID utility). I recommend that you recreate your RAID array with the new 11.6 OROM because there is a high chance that you will have to do this anyway (arrays created by older OROMs may not work). You should also check that your RST drivers are up to date because older drivers do not support RAID-0 TRIM at all. Here is a link to the latest drivers that I used in my testing, although other 11.x drivers may work as well. 

In a nutshell, that's it. You have now done all you that's necessary to enable TRIM on a 6-series motherboard. However, since all motherboards are different, I recommend trying TRIM before celebrating since there is also a lot that can go wrong.

How to Verify TRIM Is Working

You could always use the method we use but Iometer isn't exactly the most user friendly tool if you don't know what you're doing and our method involves deleting the whole volume, which also results in loss of data in the array. There is a much easier way to check the functionality of TRIM by using a hex editor and any file (credit for this method goes to XtremeSystems.org forum user Marc HFR):

1. Download and install HxD (or any other hex editor if you have a favorite).

2. Open any file you have with HxD. I used a JPG photo in this example and it worked fine. You should now see this:

3. In the right-hand column, select a string of text that is unique and copy that somewhere, you will need it later. I used the time stamp of the file because it's very likely unique, which makes the next steps easier.

4. Copy the file you opened in HxD to the root of your RAID-0 array.

5. Run HxD as an administator and open your whole RAID-0 array from Extras > Open disk.

6. Use the search tool in HxD to locate the unique text string you copied in step 3.

7. Once you have located the text string, write down the offset and sector.

8. Move the file you copied in step 4 to the recycle bin and empty it. This will delete the file and if TRIM works, the controller will also delete the data.

9. Open the RAID array in HxD again and go to the sector you recorded in step 7. If the sector is empty (full of 0's or F's), TRIM worked. If the data was not deleted, try rebooting before you start troubleshooting because it seems that a reboot is required for some SSDs to fully erase the data.


Testing TRIM on RAID-0
Comments Locked


View All Comments

  • ender8282 - Wednesday, November 28, 2012 - link

    OK that sounds a lot like what ever it was that I had on an old Abit motherboard. My experience with that setup was that unless the correct drivers were installed under windows, things didn't work right. Under Linux (mandrake I believe) it showed up as a bunch of different drives. Unless firmware raid has come a long way and supports more operating systems then just Windows, I fail to see how it is any better than software raid on Linux.

    Does software RAID under windows support trim?

    On a related note has AnandTech ever done any benchmarks between hardware, firmware, and software raid? I would be interested to read that article...
  • ender8282 - Wednesday, November 28, 2012 - link

    Probably a biased take but I found this [1] whitepaper gave a nice summary of the difference between hardware, firmware, and software.

    [1] http://www.adaptec.com/nr/rdonlyres/14b2fd84-f7a0-...
  • tecknurd - Wednesday, November 28, 2012 - link

    I disagree. The BIOS is firmware of the motherboard. Firmware is basically software for hardware that is loaded upon boot up and is not connected to the operating system in anyway. The BIOS includes RAID as software. When RAID it utilized from the motherboard, the software is loaded into memory. Mainly Windows will see this RAID software as any hardware RAID controller. Other operating system like Linux will not unless a userspace software is run first like dmraid.

    Stating Intel RAID as "firmware" RAID is a bunch of FUD. Intel RAID just does not have support to carry over the TRIM command compared to other modes of the Intel controller like AHCI.

    IMHO, Intel is all about pristine. The hack you explain is probably unsupported by Intel because is not stable and not reliable by Intel's standards.
  • extide - Wednesday, November 28, 2012 - link

    It is firmware RAID, and the software part is the driver. The RAID calculations are done in software on the main CPU, basically in the drivers. You would also need a matching driver in linux to use the 'firmware raid' as opposed to using completely software raid like dmraidc mdadm, etc.
  • tecknurd - Wednesday, November 28, 2012 - link

    Again it is not firmware RAID until you provide proof.
  • mooninite - Thursday, November 29, 2012 - link

    mdadm is used for Intel RAID as well as software Linux RAID. The Intel BIOS just writes out a special file format just like a file format for software Linux RAID. There is no decoder chip or firmware interface.
  • JonnyDough - Friday, November 30, 2012 - link

    I don't think you know what you are even saying. You must work for Intel and are trying to disprove this working fix because of "profit margins." The code was written by Intel and made to work by community software hax. Get over yourself.
  • mooninite - Thursday, November 29, 2012 - link


    Intel RAID is *not* hardware. It is a software file format of the drive called IMSM. The OS has to do all the work to read and write to the drive. There is no hardware RAID chip involved.
  • CeriseCogburn - Saturday, December 29, 2012 - link

    You still are SOL mooninite, or you'd have Linux on a decent motherboard, and then you wouldn't need it anyway.

    Oh well that's how the tor valds.
  • Conficio - Wednesday, November 28, 2012 - link

    Anyone experience (or read about) how this works in a hackintosh?

Log in

Don't have an account? Sign up now